<!DOCTYPE html>
<html amp lang="en-US" transformed="self;v=1" i-amphtml-layout="" i-amphtml-no-boilerplate="" i-amphtml-binding>

<head><meta charset="UTF-8"><meta name="viewport" content="width=device-width,minimum-scale=1"><link rel="preconnect" href="https://cdn.ampproject.org"><style amp-runtime="" i-amphtml-version="012111242025001">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</style><meta name="amp-consent-blocking" content="amp-ad,amp-iframe"><meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1"><meta name="msvalidate.01" content="808CE29E29F1230249D24A893DE871FB"><meta name="description" content="For the next few hours, you can grab the DJI Mavic Mini Fly More Combo for $299, the drone’s all-time lowest price."><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="DJI Mavic Mini Fly More Combo drops to $299 in rare deal"><meta property="og:description" content="For the next few hours, you can grab the DJI Mavic Mini Fly More Combo for $299, the drone’s all-time lowest price."><meta property="og:url" content="https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/"><meta property="og:site_name" content="DroneDJ"><meta property="article:publisher" content="https://www.facebook.com/dronedj"><meta property="article:published_time" content="2021-12-22T13:11:20+00:00"><meta property="article:modified_time" content="2021-12-22T13:11:21+00:00"><meta property="og:image" content="https://i1.wp.com/dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg?resize=1200%2C628&amp;ssl=1"><meta property="og:image:width" content="1200"><meta property="og:image:height" content="675"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:image" content="https://i1.wp.com/dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg?resize=1200%2C628&amp;ssl=1"><meta name="twitter:creator" content="@IshveenaSingh"><meta name="twitter:site" content="@dronedj"><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Ishveena Singh"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="2 minutes"><meta name="generator" content="WordPress 5.8.2"><meta name="generator" content="AMP Plugin v2.1.3; mode=standard"><meta name="msapplication-TileImage" content="https://dronedj.com/wp-content/uploads/sites/2/2017/09/dronedj-icon-hires.png?w=192"><link rel="preconnect" href="https://fonts.gstatic.com" crossorigin=""><link rel="dns-prefetch" href="https://fonts.gstatic.com"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//v0.wordpress.com"><script async="" src="https://cdn.ampproject.org/v0.mjs" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0.js" crossorigin="anonymous"></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.mjs" async="" custom-element="amp-ad" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" crossorigin="anonymous" custom-element="amp-ad"></script><script src="https://cdn.ampproject.org/v0/amp-analytics-0.1.mjs" async="" custom-element="amp-analytics" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" crossorigin="anonymous" custom-element="amp-analytics"></script><script src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.mjs" async="" custom-element="amp-auto-ads" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js" crossorigin="anonymous" custom-element="amp-auto-ads"></script><script src="https://cdn.ampproject.org/v0/amp-bind-0.1.mjs" async="" custom-element="amp-bind" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" crossorigin="anonymous" custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-carousel-0.2.mjs" async="" custom-element="amp-carousel" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-carousel-0.2.js" crossorigin="anonymous" custom-element="amp-carousel"></script><script src="https://cdn.ampproject.org/v0/amp-consent-0.1.mjs" async="" custom-element="amp-consent" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-consent-0.1.js" crossorigin="anonymous" custom-element="amp-consent"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.mjs" async="" custom-element="amp-form" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-form-0.1.js" crossorigin="anonymous" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-geo-0.1.mjs" async="" custom-element="amp-geo" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-geo-0.1.js" crossorigin="anonymous" custom-element="amp-geo"></script><script src="https://cdn.ampproject.org/v0/amp-iframe-0.1.mjs" async="" custom-element="amp-iframe" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-iframe-0.1.js" crossorigin="anonymous" custom-element="amp-iframe"></script><script src="https://cdn.ampproject.org/v0/amp-next-page-1.0.mjs" async="" custom-element="amp-next-page" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-next-page-1.0.js" crossorigin="anonymous" custom-element="amp-next-page"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.mjs" async="" custom-element="amp-social-share" type="module" crossorigin="anonymous"></script><script async nomodule src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" crossorigin="anonymous" custom-element="amp-social-share"></script><link rel="icon" href="https://dronedj.com/wp-content/uploads/sites/2/2017/09/dronedj-icon-hires.png?w=32" sizes="32x32"><link rel="icon" href="https://dronedj.com/wp-content/uploads/sites/2/2017/09/dronedj-icon-hires.png?w=192" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="google-fonts-css" href="https://fonts.googleapis.com/css2?family=Questrial&amp;display=swap&amp;ver=5.8.2" media="all"><style amp-custom="">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</style><!-- Jetpack Site Verification Tags --><!-- This site is optimized with the Yoast SEO Premium plugin v16.7 (Yoast SEO v16.7) - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/"><script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://dronedj.com/#organization","name":"DroneDJ","url":"https://dronedj.com/","sameAs":["https://www.facebook.com/dronedj","https://www.youtube.com/dronedj","https://twitter.com/dronedj"],"logo":{"@type":"ImageObject","@id":"https://dronedj.com/#logo","inLanguage":"en-US","url":"https://dronedj.com/wp-content/uploads/sites/2/2018/09/logo_dronedj_700.png","contentUrl":"https://dronedj.com/wp-content/uploads/sites/2/2018/09/logo_dronedj_700.png","width":700,"height":300,"caption":"DroneDJ"},"image":{"@id":"https://dronedj.com/#logo"}},{"@type":"WebSite","@id":"https://dronedj.com/#website","url":"https://dronedj.com/","name":"DroneDJ","description":"Drone news and views covering DJI, Skydio, Parrot and more","publisher":{"@id":"https://dronedj.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://dronedj.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/#primaryimage","inLanguage":"en-US","url":"https://dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg","contentUrl":"https://dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg","width":1200,"height":675,"caption":"dji mavic mini fly more combo deala"},{"@type":"WebPage","@id":"https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/#webpage","url":"https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/","name":"DJI Mavic Mini Fly More Combo drops to $299 in rare deal - DroneDJ","isPartOf":{"@id":"https://dronedj.com/#website"},"primaryImageOfPage":{"@id":"https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/#primaryimage"},"datePublished":"2021-12-22T13:11:20+00:00","dateModified":"2021-12-22T13:11:21+00:00","description":"For the next few hours, you can grab the DJI Mavic Mini Fly More Combo for $299, the drone\u2019s all-time lowest price.","breadcrumb":{"@id":"https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/"]}]},{"@type":"BreadcrumbList","@id":"https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://dronedj.com/"},{"@type":"ListItem","position":2,"name":"DJI Mavic Mini Fly More Combo drops to $299 in rare deal"}]},{"@type":["Article","NewsArticle"],"@id":"https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/#article","isPartOf":{"@id":"https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/#webpage"},"author":{"@id":"https://dronedj.com/#/schema/person/3d3237c11b32d6d9a29b79b774b617e5"},"headline":"DJI Mavic Mini Fly More Combo drops to $299 in rare deal","datePublished":"2021-12-22T13:11:20+00:00","dateModified":"2021-12-22T13:11:21+00:00","mainEntityOfPage":{"@id":"https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/#webpage"},"wordCount":345,"commentCount":0,"publisher":{"@id":"https://dronedj.com/#organization"},"image":{"@id":"https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/#primaryimage"},"thumbnailUrl":"https://dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg","articleSection":["News"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/#respond"]}],"copyrightYear":"2021","copyrightHolder":{"@id":"https://925.co/#organization"}},{"@type":"Person","@id":"https://dronedj.com/#/schema/person/3d3237c11b32d6d9a29b79b774b617e5","name":"Ishveena Singh","image":{"@type":"ImageObject","@id":"https://dronedj.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/7e8f4970187688d370117ced145b1f3a?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/7e8f4970187688d370117ced145b1f3a?s=96&d=mm&r=g","caption":"Ishveena Singh"},"description":"Ishveena Singh is a versatile journalist and writer with a passion for drones and location technologies. She has been named as one of the 50 Rising Stars of the geospatial industry for the year 2021 by Geospatial World magazine.","sameAs":["https://www.linkedin.com/in/ishveena/","https://twitter.com/IshveenaSingh"],"url":"https://dronedj.com/author/ishveenasingh/"}]}</script><!-- / Yoast SEO Premium plugin. --><link rel="alternate" type="application/rss+xml" title="DroneDJ » Feed" href="https://dronedj.com/feed/"><link rel="alternate" type="application/rss+xml" title="DroneDJ » Comments Feed" href="https://dronedj.com/comments/feed/"><link rel="alternate" type="application/rss+xml" title="DroneDJ » DJI Mavic Mini Fly More Combo drops to $299 in rare deal Comments Feed" href="https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/feed/"><link rel="https://api.w.org/" href="https://dronedj.com/wp-json/"><link rel="alternate" type="application/json" href="https://dronedj.com/wp-json/wp/v2/posts/73834"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dronedj.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dronedj.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://wp.me/p9Rwpe-jcS"><link rel="alternate" type="application/json+oembed" href="https://dronedj.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdronedj.com%2F2021%2F12%2F22%2Fdji-mavic-mini-fly-more-combo-299-deal%2F"><link rel="alternate" type="text/xml+oembed" href="https://dronedj.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdronedj.com%2F2021%2F12%2F22%2Fdji-mavic-mini-fly-more-combo-299-deal%2F&amp;format=xml"><!-- Stream WordPress user activity plugin v3.7.0 --><link rel="apple-touch-icon" href="https://dronedj.com/wp-content/uploads/sites/2/2017/09/dronedj-icon-hires.png?w=180"><title>DJI Mavic Mini Fly More Combo drops to $299 in rare deal - DroneDJ</title></head>

<body class="post-template-default single single-post postid-73834 single-format-standard wp-embed-responsive color-scheme-dronedj"><amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed">
			<script type="application/json">
				{"vars":{"gtag_id":"UA-106928451-1","config":{"UA-106928451-1":{"groups":"default"}}},"triggers":{"trackScrollThrough":{"on":"amp-next-page-scroll","request":"nextpage"},"trackClickThrough":{"on":"amp-next-page-click","request":"nextpage"}},"extraUrlParams":{"cg1":"dji%2Cdji-mavic-mini","cg2":"ishveenasingh"}}			</script>
		</amp-analytics>
	<amp-auto-ads type="adsense" data-ad-client="ca-pub-4931339094089841" class="i-amphtml-layout-container" i-amphtml-layout="container"></amp-auto-ads>	<div class="consent-wrapper consent-wrapper-overlay">
		<amp-iframe title="User Sync" data-block-on-consent width="1" height="1" sandbox="allow-scripts allow-same-origin" frameborder="0" src="https://static.s2s.t13.io/generic/load-cookie.html" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed">
			<amp-img layout="fill" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" placeholder class="i-amphtml-layout-fill i-amphtml-layout-size-defined" i-amphtml-layout="fill"></amp-img>
		</amp-iframe>
			<amp-geo layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<script type="application/json">
			{
				"ISOCountryGroups": {
					"eea": ["preset-eea", "unknown"],
					"ccpa": ["preset-us-ca"]
				}
			}
		</script>
	</amp-geo>
	<amp-consent id="consent" layout="nodisplay" type="SourcePoint" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<script type="application/json">
			{
				"consentInstanceId": "sourcepoint",
				"consentRequired": false,
				"checkConsentHref": "https://t13.dronedj.com/ccpa/consent/amp",
				"geoOverride": {
					"ccpa": {
						"consentRequired": "remote",
						"checkConsentHref": "https://t13.dronedj.com/ccpa/consent/amp",
						"promptUISrc": "https://t13.dronedj.com/amp/index.html?authId=CLIENT_ID",
						"postPromptUI": "ccpa-consent-ui",
						"clientConfig": {
							"accountId": 1638,
							"siteHref": "https://ccpa.amp.dronedj.com",
							"siteId": 16063,
							"isCCPA": true,
							"stageCampaign": false,
							"privacyManagerId": "6022b85a892e762cb08504d0",
							"getDnsMsgMms": true,
							"alwaysDisplayDns": false,
							"showNoticeUntilAction": true
						}
					},
					"eea": {
						"consentRequired": "remote",
						"checkConsentHref": "https://t13.dronedj.com/wrapper/tcfv2/v1/amp-v2",
						"promptUISrc": "https://t13.dronedj.com/amp/index.html?authId=CLIENT_ID",
						"postPromptUI": "eea-consent-ui",
						"clientConfig": {
							"accountId": 1638,
							"mmsDomain": "https://t13.dronedj.com",
							"propertyHref": "https://amp.dronedj.com",
							"propertyId": 16064,
							"privacyManagerId": 426503,
							"isTCFV2": true,
							"pmTab": "purposes",
							"stageCampaign": false
						}
					}
				}
			}
		</script>
	</amp-consent>
		</div>

	<header class="site-hd" next-page-hide>
		<div class="hd-top">
			<div data-amp-bind-class="mobileMenuActive ? 'wrap flex flx--alignc flx--end bb-gr-xlt py-0 active' : 'wrap flex flx--alignc flx--end bb-gr-xlt py-0'" class="wrap flex flx--alignc flx--end bb-gr-xlt py-0" i-amphtml-binding>
				<div class="flex mr-at">
					<button on="tap:AMP.setState( { mobileMenuActive: !mobileMenuActive, drawerActive: false, mobileSearchActive: false } )" data-amp-bind-class="mobileMenuActive ? 'mm-tgl mr-4 active' : 'mm-tgl mr-4'" class="mm-tgl mr-4" aria-expanded="false" data-amp-bind-aria-expanded="mobileMenuActive ? 'true' : 'false'" i-amphtml-binding>
						<span class="sr-txt">Menu</span>
						<span class="burger"></span>
					</button>
											<figure class="site-logo">
							<a href="https://dronedj.com">
								
	<svg class="icon icon-ninetofive-dronedj mt-2 mr-2" aria-hidden="true">
		<title id="title-ninetofive-dronedj-12396">ninetofive-dronedj</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-ninetofive-dronedj"></use>
			</svg>

	
															</a>
						</figure>
											<button on="tap:AMP.setState( { drawerActive: !drawerActive, mobileMenuActive: false, mobileSearchActive: false } )" data-amp-bind-class="drawerActive ? 'drawer-tgl active flx--center' : 'drawer-tgl flx--center'" class="drawer-tgl flex flx--center" role="toggle" aria-expanded="false" data-amp-bind-aria-expanded="drawerActive ? 'true' : 'false'" i-amphtml-binding>
						
	<svg class="icon icon-chevron-down " height="8" width="13" aria-hidden="true">
		<title id="title-chevron-down-60262">chevron-down</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-chevron-down"></use>
			</svg>

							<span class="sr-txt">Switch Site</span>
					</button>
				</div>

					<nav data-amp-bind-class="mobileMenuActive ? 'nav-social vplg:mt-0 active flex' : 'nav-social vplg:mt-0 flex'" aria-hidden="true" data-amp-bind-aria-hidden="mobileMenuActive ? 'false' : 'true'" class="nav-social vplg:mt-0 flex" i-amphtml-binding>
	<ul id="menu-social" class="menu flex flx--alignc py-0 pl-0"><li id="nav-menu-item-64143" class="menu-item menu-item-type-custom menu-item-object-custom main-menu-item menu-item-depth-0 "><a title="Follow DroneDJ on YouTube" href="https://www.youtube.com/dronedj" class="menu-link main-menu-link p-3 vplg:py-0 vplg:px-2">
	<svg class="icon icon-youtube ic-sm" aria-hidden="true">
		<title id="title-youtube-32942">YouTube</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-youtube"></use>
			</svg>

	</a></li>
<li id="nav-menu-item-64144" class="menu-item menu-item-type-custom menu-item-object-custom main-menu-item menu-item-depth-0 "><a title="Follow DroneDJ on Facebook" href="https://www.facebook.com/dronedj" class="menu-link main-menu-link p-3 vplg:py-0 vplg:px-2">
	<svg class="icon icon-facebook ic-sm" aria-hidden="true">
		<title id="title-facebook-87965">Facebook</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-facebook"></use>
			</svg>

	</a></li>
<li id="nav-menu-item-64145" class="menu-item menu-item-type-custom menu-item-object-custom main-menu-item menu-item-depth-0 "><a title="Follow DroneDJ on Twitter" href="https://twitter.com/dronedj" class="menu-link main-menu-link p-3 vplg:py-0 vplg:px-2">
	<svg class="icon icon-twitter ic-sm" aria-hidden="true">
		<title id="title-twitter-2242">Twitter</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-twitter"></use>
			</svg>

	</a></li>
<li id="nav-menu-item-64142" class="menu-item menu-item-type-post_type menu-item-object-page main-menu-item menu-item-depth-0 "><a title="Follow DroneDJ on Follow" href="https://dronedj.com/follow/" class="menu-link main-menu-link p-3 vplg:py-0 vplg:px-2">
	<svg class="icon icon-expand ic-sm" aria-hidden="true">
		<title id="title-follow-80021">Follow</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-expand"></use>
			</svg>

	</a></li>
</ul>	</nav>
	<nav data-amp-bind-class="mobileMenuActive ? 'nav-utility vplg:mt-0 active flex' : 'nav-utility vplg:mt-0 flex'" aria-hidden="true" data-amp-bind-aria-hidden="mobileMenuActive ? 'false' : 'true'" class="nav-utility vplg:mt-0 flex" i-amphtml-binding>
	<ul id="menu-utility" class="menu flex flx--alignc py-0 pl-0"><li id="nav-menu-item-827" class="icon-comment menu-item menu-item-type-post_type menu-item-object-page main-menu-item menu-item-depth-0 "><a title="Submit a Tip / Contact Us" href="https://dronedj.com/contact/" class="menu-link main-menu-link p-3 vplg:py-0 vplg:px-2">
	<svg class="icon icon-comment ic-sm" aria-hidden="true">
		<title id="title-submit-a-tip-contact-us-10068">Submit a Tip / Contact Us</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-comment"></use>
			</svg>

	</a></li>
</ul>	</nav>

				<button on="tap:AMP.setState( { mobileSearchActive: !mobileSearchActive, mobileMenuActive: false, drawerActive: false } )" data-amp-bind-class="mobileSearchActive ? 'srch-tgl active' : 'srch-tgl'" class="srch-tgl" role="toggle" aria-expanded="false" data-amp-bind-aria-expanded="mobileSearchActive ? 'true' : 'false'" i-amphtml-binding>
					<span class="sr-txt">Toggle search"</span>
					<svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 23 22">
						<path fill="none" stroke="currentColor" stroke-width="2" stroke-linecap="round" stroke-linejoin="round" d="M9.885,1
						c4.734,0,8.571,3.838,8.571,8.571s-3.838,8.571-8.571,8.571s-8.571-3.838-8.571-8.571S5.152,1,9.885,1z M16.314,16l5,5"></path>
					</svg>
				</button>

				
<div itemscope itemtype="http://schema.org/WebSite" data-amp-bind-class="mobileSearchActive ? 'hd-srch active' : 'hd-srch'" class="hd-srch" aria-hidden="true" data-amp-bind-aria-hidden="mobileSearchActive ? 'false' : 'true'" i-amphtml-binding>
	<form role="search" id="searchform" class="search-form mt-0 vplg:mt-0 vplg:ml-5 flex" method="get" action="https://dronedj.com/" target="_top">
		<meta itemprop="target" content="https://dronedj.com/?s={s}">
		<label for="search-field" class="sr-txt">
			Search for:		</label>
				<input itemprop="query-input" type="search" id="search-field" value="" placeholder="Search DroneDJ" name="s" class="py-2 pl-2 fs-xs pr-6 flx--g1 py-3">
	</form>
</div>

			</div>
		</div>
		<div class="drawer-nav">
			<div class="wrap">
					<nav data-amp-bind-class="drawerActive ? 'nav-drawer vpmd:mt-0 active' : 'nav-drawer vpmd:mt-0'" aria-hidden="true" data-amp-bind-aria-hidden="drawerActive ? 'false' : 'true'" class="nav-drawer vpmd:mt-0" i-amphtml-binding>
	<ul id="menu-site-menu" class="menu drawer-menu flex flx--alignc flx--sb">
<li class="menu-item-logo menu-item-ninetofive-mac"><a class="py-3" href="https://9to5mac.com/">
	<svg class="icon icon-ninetofive-mac " aria-hidden="true">
		<title id="title-ninetofive-mac-88690">ninetofive-mac</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-ninetofive-mac"></use>
			</svg>

	<span class="sr-txt">9to5Mac</span></a></li>


<li class="menu-item-logo menu-item-ninetofive-google"><a class="py-3" href="https://9to5google.com/">
	<svg class="icon icon-ninetofive-google " aria-hidden="true">
		<title id="title-ninetofive-google-46473">ninetofive-google</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-ninetofive-google"></use>
			</svg>

	<span class="sr-txt">9to5Google</span></a></li>


<li class="menu-item-logo menu-item-ninetofive-toys"><a class="py-3" href="https://9to5toys.com/">
	<svg class="icon icon-ninetofive-toys " aria-hidden="true">
		<title id="title-ninetofive-toys-63909">ninetofive-toys</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-ninetofive-toys"></use>
			</svg>

	<span class="sr-txt">9to5Toys</span></a></li>


<li class="menu-item-logo menu-item-ninetofive-electrek"><a class="py-3" href="https://electrek.co/">
	<svg class="icon icon-ninetofive-electrek " aria-hidden="true">
		<title id="title-ninetofive-electrek-23116">ninetofive-electrek</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-ninetofive-electrek"></use>
			</svg>

	<span class="sr-txt">Electrek</span></a></li>


<li class="menu-item-logo menu-item-ninetofive-spaceexplored"><a class="py-3" href="https://spaceexplored.com/">
	<svg class="icon icon-ninetofive-spaceexplored " aria-hidden="true">
		<title id="title-ninetofive-spaceexplored-17615">ninetofive-spaceexplored</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-ninetofive-spaceexplored"></use>
			</svg>

	<span class="sr-txt">SpaceExplored</span></a></li>


<li class="menu-item-link"><a class="py-3" href="https://dronedj.com/about-dronedj/">About</a></li>


<li class="menu-item-link"><a class="py-3" href="https://dronedj.com/privacy/">Privacy</a></li>

</ul>
	<ul class="consent-wrapper drawer-menu pb-4">
		<li id="ccpa-consent-ui" class="consent-ccpa">
			<a on="tap:consent.prompt(consent=SourcePoint)" role="button" tabindex="0">Do Not Sell My Info</a>
		</li>

		<li id="eea-consent-ui" class="consent-eea">
			<a on="tap:consent.prompt(consent=SourcePoint)" role="button" tabindex="0">Privacy Settings</a>
		</li>
	</ul>

		</nav>
			</div>
		</div>
		<div class="hd-nav">
			<div data-amp-bind-class="mobileMenuActive ? 'wrap active' : 'wrap'" class="wrap" i-amphtml-binding>
								<nav data-amp-bind-class="mobileMenuActive ? 'nav-primary nav-menu active' : 'nav-primary nav-menu'" class="nav-primary nav-menu" aria-hidden="true" data-amp-bind-aria-hidden="mobileMenuActive ? 'false' : 'true'" i-amphtml-binding>
	<ul id="menu-guides" class="primary-menu-ul fs-xs fw-sb"><li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-has-children menu-item-18"><a href="https://dronedj.com/guides/dji/" class="py-3 px-4 vplg:p-3">DJI</a>
<ul class="sub-menu">
	<li id="menu-item-4953" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4953"><a href="https://dronedj.com/guides/dji-mavic-air-2/" class="py-3 px-4 vplg:p-3">DJI Mavic Air 2</a></li>
	<li id="menu-item-28053" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-28053"><a href="https://dronedj.com/guides/dji-mavic-mini/" class="py-3 px-4 vplg:p-3">DJI Mavic Mini</a></li>
	<li id="menu-item-41709" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-41709"><a href="https://dronedj.com/guides/dji-mini-2/" class="py-3 px-4 vplg:p-3">DJI Mini 2</a></li>
	<li id="menu-item-10933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10933"><a href="https://dronedj.com/guides/dji-mavic-2/" class="py-3 px-4 vplg:p-3">DJI Mavic 2 Zoom and Pro</a></li>
	<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-19"><a href="https://dronedj.com/guides/dji-inspire/" class="py-3 px-4 vplg:p-3">DJI Inspire</a></li>
	<li id="menu-item-20" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-20"><a href="https://dronedj.com/guides/dji-mavic-pro-platinum/" class="py-3 px-4 vplg:p-3">DJI Mavic Pro</a></li>
	<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-21"><a href="https://dronedj.com/guides/dji-phantom-4/" class="py-3 px-4 vplg:p-3">DJI Phantom 4</a></li>
	<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-22"><a href="https://dronedj.com/guides/dji-spark/" class="py-3 px-4 vplg:p-3">DJI Spark</a></li>
</ul>
</li>
<li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-25"><a href="https://dronedj.com/guides/parrot/" class="py-3 px-4 vplg:p-3">Parrot</a></li>
<li id="menu-item-31038" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-31038"><a href="https://dronedj.com/guides/skydio/" class="py-3 px-4 vplg:p-3">Skydio</a></li>
<li id="menu-item-41704" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-41704"><a href="https://dronedj.com/guides/ehang/" class="py-3 px-4 vplg:p-3">EHang</a></li>
<li id="menu-item-27678" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27678"><a href="https://dronedj.com/guides/autel-evo-2/" class="py-3 px-4 vplg:p-3">Autel</a></li>
<li id="menu-item-41707" class="menu-item menu-item-type-taxonomy menu-item-object-ninetofive_guides menu-item-41707"><a href="https://dronedj.com/guides/swellpro/" class="py-3 px-4 vplg:p-3">SwellPro</a></li>
<li id="menu-item-4955" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4955"><a href="https://dronedj.com/guides/dronedj-review/" class="py-3 px-4 vplg:p-3">Reviews</a></li>
<li id="menu-item-41376" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41376"><a href="https://dronedj.com/guides/long-reads/" class="py-3 px-4 vplg:p-3">Long Reads</a></li>
</ul></nav>
	<nav data-amp-bind-class="mobileMenuActive ? 'nav-social vplg:mt-0 active flex' : 'nav-social vplg:mt-0 flex'" aria-hidden="true" data-amp-bind-aria-hidden="mobileMenuActive ? 'false' : 'true'" class="nav-social vplg:mt-0 flex" i-amphtml-binding>
	<ul id="menu-social-1" class="menu flex flx--alignc py-0 pl-0"><li id="nav-menu-item-64143" class="menu-item menu-item-type-custom menu-item-object-custom main-menu-item menu-item-depth-0 "><a title="Follow DroneDJ on YouTube" href="https://www.youtube.com/dronedj" class="menu-link main-menu-link p-3 vplg:py-0 vplg:px-2">
	<svg class="icon icon-youtube ic-sm" aria-hidden="true">
		<title id="title-youtube-81427">YouTube</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-youtube"></use>
			</svg>

	</a></li>
<li id="nav-menu-item-64144" class="menu-item menu-item-type-custom menu-item-object-custom main-menu-item menu-item-depth-0 "><a title="Follow DroneDJ on Facebook" href="https://www.facebook.com/dronedj" class="menu-link main-menu-link p-3 vplg:py-0 vplg:px-2">
	<svg class="icon icon-facebook ic-sm" aria-hidden="true">
		<title id="title-facebook-43100">Facebook</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-facebook"></use>
			</svg>

	</a></li>
<li id="nav-menu-item-64145" class="menu-item menu-item-type-custom menu-item-object-custom main-menu-item menu-item-depth-0 "><a title="Follow DroneDJ on Twitter" href="https://twitter.com/dronedj" class="menu-link main-menu-link p-3 vplg:py-0 vplg:px-2">
	<svg class="icon icon-twitter ic-sm" aria-hidden="true">
		<title id="title-twitter-29056">Twitter</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-twitter"></use>
			</svg>

	</a></li>
<li id="nav-menu-item-64142" class="menu-item menu-item-type-post_type menu-item-object-page main-menu-item menu-item-depth-0 "><a title="Follow DroneDJ on Follow" href="https://dronedj.com/follow/" class="menu-link main-menu-link p-3 vplg:py-0 vplg:px-2">
	<svg class="icon icon-expand ic-sm" aria-hidden="true">
		<title id="title-follow-71579">Follow</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-expand"></use>
			</svg>

	</a></li>
</ul>	</nav>
	<nav data-amp-bind-class="mobileMenuActive ? 'nav-utility vplg:mt-0 active flex' : 'nav-utility vplg:mt-0 flex'" aria-hidden="true" data-amp-bind-aria-hidden="mobileMenuActive ? 'false' : 'true'" class="nav-utility vplg:mt-0 flex" i-amphtml-binding>
	<ul id="menu-utility-1" class="menu flex flx--alignc py-0 pl-0"><li id="nav-menu-item-827" class="icon-comment menu-item menu-item-type-post_type menu-item-object-page main-menu-item menu-item-depth-0 "><a title="Submit a Tip / Contact Us" href="https://dronedj.com/contact/" class="menu-link main-menu-link p-3 vplg:py-0 vplg:px-2">
	<svg class="icon icon-comment ic-sm" aria-hidden="true">
		<title id="title-submit-a-tip-contact-us-56950">Submit a Tip / Contact Us</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-comment"></use>
			</svg>

	</a></li>
</ul>	</nav>
			</div>
		</div>


		<!-- .primary-menu -->
		
	</header>

	
		<div class="slot bg-striped slot-leaderboard">
		<div class="aligncenter py-4">

		<amp-ad class="unit-mobile i-amphtml-layout-fixed i-amphtml-layout-size-defined" width="350" height="50" layout="fixed" data-multi-size="350x50,350x75,320x100" data-multi-size-validation="false" type="doubleclick" data-slot="/15188745,1049447/9to5DroneDJ-AMP/AMP-Leaderboard-Mobile" json="" data-enable-refresh="30" data-loading-strategy="1.25" rtc-config='{
				"vendors": {
					"t13": {
						"TAG_ID": "43403eac-982b-421c-a8b7-ab94520c76c9",
						"ACCOUNT_ID": "9a3c6c23-453a-4cba-b419-30b908f39a50"
					},
					"aps": {
						"PUB_ID": "600",
						"PUB_UUID": "16268e26-dabe-4bf4-a28f-b8f4ee192ed3",
						"PARAMS":{"amp":"1"}
					},
					"criteo":{
						"NETWORK_ID": 4905,
						"ZONE_ID": 1382491,
						"PUBLISHER_SUB_ID": "9to5DroneDJ-AMP-Leaderboard-Mobile"
					},
					"medianet": {
						"CID": "8CU8ZT2C4"
					}
				},
				"urls": [
					"https://api.floors.dev/sgw/v1/amp/floors?k=QBNaieBwWeBYMRGsreCNdCsuWLTtmZ&amp;sid=22369280984"
				]
			}' id="i-amp-0" style="width:350px;height:50px" i-amphtml-layout="fixed">
		</amp-ad><amp-ad class="unit-desktop i-amphtml-layout-fixed i-amphtml-layout-size-defined" width="970" height="250" layout="fixed" data-multi-size="970x90,970x66,970x70,728x90,468x60,336x280,300x250" data-multi-size-validation="false" type="doubleclick" data-slot="/15188745,1049447/9to5DroneDJ-AMP/AMP-Leaderboard-Desktop" json="" data-enable-refresh="30" data-loading-strategy="1.25" rtc-config='{
				"vendors": {
					"t13": {
						"TAG_ID": "e0c14963-9fba-4284-90b8-40fc844099e3",
						"ACCOUNT_ID": "9a3c6c23-453a-4cba-b419-30b908f39a50"
					},
					"aps": {
						"PUB_ID": "600",
						"PUB_UUID": "16268e26-dabe-4bf4-a28f-b8f4ee192ed3",
						"PARAMS":{"amp":"1"}
					},
					"criteo":{
						"NETWORK_ID": 4905,
						"ZONE_ID": 1382491,
						"PUBLISHER_SUB_ID": "9to5DroneDJ-AMP-Leaderboard-Desktop"
					},
					"medianet": {
						"CID": "8CU8ZT2C4"
					}
				},
				"urls": [
					"https://api.floors.dev/sgw/v1/amp/floors?k=QBNaieBwWeBYMRGsreCNdCsuWLTtmZ&amp;sid=22369280984"
				]
			}' id="i-amp-1" style="width:970px;height:250px" i-amphtml-layout="fixed">
		</amp-ad>		</div>
	</div>

						<main class="site-main mt-4 vpmd:mt-9">
				<article id="post-73834" class="post-73834 post type-post status-publish format-standard has-post-thumbnail hentry category-news ninetofive_guides-dji ninetofive_guides-dji-mavic-mini" itemscope itemtype="http://schema.org/NewsArticle">

					<div itemprop="mainEntityOfPage">

						<h1 class="entry-title wrap-sm" itemprop="headline">
							<a class="txt-blk" href="https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/">
								DJI Mavic Mini Fly More Combo drops to $299 in rare deal							</a>
						</h1>

						
<div class="wrap-sm entry-meta mb-5 vpmd:mb-6 flex flx--sb flx--alignc">
	<div class="byline-date entry-meta-column fs-xs fw-rg mb-5 vplg:mb-0">
		  <a class="txt-sc" href="https://dronedj.com/author/ishveenasingh/"><span itemprop="author">Ishveena Singh</span></a>		<span class="divider"> - </span>
		<time datetime="2021-12-22 05:11:20" itemprop="datePublished">Dec. 22nd 2021 5:11 am PT</time>
		<time datetime="2021-12-22 05:11:21" itemprop="dateModified"></time>

		<a href="https://twitter.com/IshveenaSingh" class="author__twitter fs-xs txt-bl"><span class="icon-twitter ml-1 va-middle d-inline-block vpmd:mt-1 mr-2">
	<svg class="icon icon-twitter " fill="#78bbf4" height="13" width="16" aria-hidden="true">
		<title id="title-twitter-icon-31065">Twitter icon</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-twitter"></use>
			</svg>

	</span><span>@IshveenaSingh</span></a>	</div>

			<div class="entry-tags entry-meta-column">
			<a href="https://dronedj.com/guides/dji/" class="btn bg-gr-lt sm post-tag txt-up mr-2 my-1 fs-sm-md">DJI</a><a href="https://dronedj.com/guides/dji-mavic-mini/" class="btn bg-gr-lt sm post-tag txt-up mr-2 my-1 fs-sm-md">DJI Mavic Mini</a>		</div>
	</div>

													<div class="post-featured-image wrap-md" data-amp-auto-lightbox-disable>
																<amp-img width="1200" height="600" src="https://dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg?w=1200&amp;h=600&amp;crop=1" class="attachment-ratio-21 size-ratio-21 wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="dji mavic mini fly more combo deala" srcset="https://dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg?resize=1200,600 1200w, https://dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg?resize=600,300 600w" sizes="(max-width: 1200px) 100vw, 1200px" data-hero-candidate="" layout="intrinsic" disable-inline-width="" data-hero i-amphtml-ssr i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjYwMCIgd2lkdGg9IjEyMDAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" loading="lazy" alt="dji mavic mini fly more combo deala" src="https://dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg?w=1200&amp;h=600&amp;crop=1" srcset="https://dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg?resize=1200,600 1200w, https://dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg?resize=600,300 600w" sizes="(max-width: 1200px) 100vw, 1200px"></amp-img>	<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
		<meta itemprop="url" content="https://dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg?w=1024">
		<meta itemprop="width" content="1200">
		<meta itemprop="height" content="675">
	</div><!--/itemprop=image-->
							</div>
						
							<div class="social__share wrap-md">
		<div class="social__share-inner flex flx--center mb-5">
			<a class="bg-blk txt-wht px-3 fs-xs" href="https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/#comments" itemprop="discussionUrl">Comments</a>
			<amp-social-share type="facebook" data-param-app_id="966242223397117" width="32" height="32" class="social-share-facebook-custom-class i-amphtml-layout-fixed i-amphtml-layout-size-defined" data-param-href="https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/" data-param-text="DJI Mavic Mini Fly More Combo drops to $299 in rare deal" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share>
			<amp-social-share type="twitter" width="32" height="32" class="social-share-twitter-custom-class i-amphtml-layout-fixed i-amphtml-layout-size-defined" data-param-url="https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/" data-param-text="DJI Mavic Mini Fly More Combo drops to $299 in rare deal" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share>
			<amp-social-share type="pinterest" data-param-media="https://dronedj.com/wp-content/uploads/sites/2/2021/12/dji-mavic-mini-fly-more-combo-deala.jpg?w=1024" width="32" height="32" class="social-share-pinterest-custom-class i-amphtml-layout-fixed i-amphtml-layout-size-defined" data-param-url="https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/" data-param-description="DJI Mavic Mini Fly More Combo drops to $299 in rare deal" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share>
			<amp-social-share type="linkedin" width="32" height="32" class="social-share-linkedin-custom-class i-amphtml-layout-fixed i-amphtml-layout-size-defined" data-param-url="https://dronedj.com/2021/12/22/dji-mavic-mini-fly-more-combo-299-deal/" data-param-text="DJI Mavic Mini Fly More Combo drops to $299 in rare deal" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share>
			<a href="https://www.reddit.com/submit?url=https%3A%2F%2Fdronedj.com%2F2021%2F12%2F22%2Fdji-mavic-mini-fly-more-combo-299-deal%2F" target="_blank" class="amp-social-share-reddit"></a>
		</div>
	</div>

						<div class="entry-content post-body wrap-sm mt-6" itemprop="articleBody">
							
<p>For the next few hours, you can grab the DJI Mavic Mini Fly More Combo for $299, the drone’s all-time lowest price.</p>



<span id="more-73834"></span><amp-ad width="300" height="250" type="adsense" data-ad-host="ca-host-pub-5506057612223327" data-ad-client="ca-pub-4931339094089841" class="unit-author m-at my-5 vpmd:mt-4 vpmd:mx-5 i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px" i-amphtml-layout="fixed"></amp-ad>



<p>Originally launched at $499 in 2019 and offered more recently for $399, one of the most dependable beginner’s drones right now can be picked up for only $299 at <a href="https://bit.ly/3Fobx4F" target="_blank" rel="noreferrer noopener">B&amp;H Photo</a>, complete with its must-have accessories like an extra pair of batteries and propeller blades.</p>



<p>The reason the sub-250-gram drone is seeing such a heavy discount is that DJI has discontinued this model. But at $299, the Mavic Mini Fly More Combo is $150 cheaper than the standalone version of its successor, <a href="https://bit.ly/30OEBmP" target="_blank" rel="noreferrer noopener">Mini 2</a>, and matches the price of the standalone version of the recently released <a href="https://bit.ly/3yNYC9Q" target="_blank" rel="noreferrer noopener">Mini SE</a> (which essentially uses the same internal components of the Mavic Mini in the shell of the Mini 2). </p>



<p>Also, DJI is still rolling out <a href="https://dronedj.com/2021/12/07/dji-mavic-mini-firmware-update-3/" target="_blank" rel="noreferrer noopener">new firmware updates</a> for the Mavic Mini, which basically tells you that while the aircraft may not be on the production line anymore, the drone maker has no plans to abandon it in terms of support, spares, and technical assistance.</p>



<p>The Mavic Mini shoots video at up to 2.7K resolution at 30 fps, and 1080 at 60fps. It can achieve up to 12MP images. The drone’s camera is mounted on a stabilized 3-axis gimbal and sophisticated flight modes ensure that you can capture complex, cinematic shots with just a tap in the DJI Fly app. The drone features up to 30 minutes of flight time on a full battery charge.</p>



<p>Yes, it would have been great to have 4K video recording, but <a href="https://bit.ly/3Fobx4F" target="_blank" rel="noreferrer noopener">$299</a> is truly a bargain for an awesome mini drone combo that is perfect for traveling and capturing epic shots. So, if you’re looking for your first drone, or an affordable drone, or simply a fantastic gift for someone special, grab the <a href="https://bit.ly/3Fobx4F" target="_blank" rel="noreferrer noopener">DJI Mavic Mini Fly More Combo</a> while it’s at an all-time low price.</p>



<p><strong>Read more:</strong> <a href="https://dronedj.com/2021/12/21/dji-skypixel-drone-photo-video-contest-2021/">DJI’s annual SkyPixel drone photo &amp; video contest is back with almost $100K in prizes</a></p>
<div class="ad-disclaimer-container"><p class="disclaimer-affiliate"><em>FTC: DroneDJ is reader supported, we may earn income on <a href="https://dronedj.com/about-dronedj/#affiliate">affiliate links</a></em></p><a href="https://amzn.to/3bGbEez"><amp-img class="alignnone size-medium wp-image-69121 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" src="https://dronedj.com/wp-content/uploads/sites/2/2021/11/DJI-MAvic-3-discount-1.jpeg" alt="DJI FPV discount sale" width="970" height="250" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjI1MCIgd2lkdGg9Ijk3MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img src="https://dronedj.com/wp-content/uploads/sites/2/2021/11/DJI-MAvic-3-discount-1.jpeg" alt="DJI FPV discount sale" width="970" height="250"></noscript></amp-img> </a></div><div id="after_disclaimer_placement"></div><hr>
<p data-amp-original-style="text-align: center" class="amp-wp-7023da7"><a href="https://www.youtube.com/channel/UCXQ8Rk4HPF5LZ-a0My7wDlw?sub_confirmation=1">Subscribe to DroneDJ on YouTube for exclusive videos</a><!-- youtube embed -->
		</p><div class="fluid-width-video-wrapper">
			<amp-iframe title="Recent Videos" src="https://www.youtube.com/embed/ad0GgEVL8nk?playlist=CRuTv9r_AYw,-SwZYVpPqUo,92EY6HtYA94,NEqMT9OLAbY,eMlIVPwIh8U,w42t6RVCss8,YIePxB59X6o,6rxT1iX-voA,eJBHvAKwaPo" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" width="1000" height="563" sandbox="allow-downloads allow-forms allow-modals allow-orientation-lock allow-pointer-lock allow-popups allow-popups-to-escape-sandbox allow-presentation allow-same-origin allow-scripts allow-top-navigation-by-user-activation" layout="intrinsic" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjU2MyIgd2lkdGg9IjEwMDAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><span placeholder="" class="amp-wp-iframe-placeholder"></span><noscript><iframe title="Recent Videos" src="https://www.youtube.com/embed/ad0GgEVL8nk?playlist=CRuTv9r_AYw,-SwZYVpPqUo,92EY6HtYA94,NEqMT9OLAbY,eMlIVPwIh8U,w42t6RVCss8,YIePxB59X6o,6rxT1iX-voA,eJBHvAKwaPo" frameborder="0" width="1000" height="563">
			</iframe></noscript></amp-iframe>
		</div>						</div>

						

<div class="entry-guides section-footer wrap-xs mt-5 vpmd:mt-7">
	<div class="entry-guides-inner bb-gr-xlt bl-gr-xlt br-gr-xlt bt-2-pc">
		<h2 class="pt-2 px-5">Guides</h2>
		<div class="featured-guides flex x2 vpmd:flx--nowrp bt-gr-xlt">
							<div class="item flex p-5 pb-4">
					<div class="image">
						<a href="https://dronedj.com/guides/dji/" tabindex="-1">
							<amp-img height="84" width="84" src="https://i2.wp.com/dronedj.com/wp-content/uploads/sites/2/2020/10/DJI-top-commercial-drone-maker.jpg?resize=200%2C200&amp;ssl=1" title="DJI" alt="DJI" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:84px;height:84px" i-amphtml-layout="fixed">
							</amp-img>
						</a>
					</div>

					<div class="guide-content flx-0 pl-5">
						<h3>
							<a href="https://dronedj.com/guides/dji/" title="">
								DJI							</a>
						</h3>

													<div class="fs-xs">Da-Jiang Innovations, better known as DJI, is the world leader in drone technology with about 70% of the market share worldwide. The company is best…</div>
											</div>
				</div>
							<div class="item flex p-5 pb-4">
					<div class="image">
						<a href="https://dronedj.com/guides/dji-mavic-mini/" tabindex="-1">
							<amp-img height="84" width="84" src="https://i1.wp.com/dronedj.com/wp-content/themes/9to5-amp/images/default-dronedj-guide.jpg?resize=200%2C200&amp;ssl=1" title="DJI Mavic Mini" alt="DJI Mavic Mini" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:84px;height:84px" i-amphtml-layout="fixed">
							</amp-img>
						</a>
					</div>

					<div class="guide-content flx-0 pl-5">
						<h3>
							<a href="https://dronedj.com/guides/dji-mavic-mini/" title="">
								DJI Mavic Mini							</a>
						</h3>

													<div class="fs-xs">DJI Mavic Mini was announced on October 30th 2019 and costs $399 for the Standard version and $499 for the DJI Mavic Mini Fly More…</div>
											</div>
				</div>
					</div>

			</div>
</div>
	<div class="entry-author section-footer wrap-xs mt-5 vpmd:mt-7">
		<div class="entry-author-inner bb-gr-xlt bl-gr-xlt br-gr-xlt bt-2-pc">
			<h2 class="pt-2 px-5">About the Author</h2>
			<div class="author-bio bt-gr-xlt p-5" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<div class="item flex">
					<a href="https://dronedj.com/author/ishveenasingh/" class="amp-post-details-item-image">
						<amp-img src="https://secure.gravatar.com/avatar/7e8f4970187688d370117ced145b1f3a?s=256&amp;d=mm&amp;r=g" width="84" height="84" class="author-gravatar i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:84px;height:84px" i-amphtml-layout="fixed">
						</amp-img>
					</a>
					<div class="author-content flex flx-0 pl-5">
						<h3>
							<a class="flex" href="https://dronedj.com/author/ishveenasingh/">
								<span class="mr-4" itemprop="name">Ishveena Singh</span>
							</a>
						</h3>
						<a href="https://twitter.com/IshveenaSingh" class="author__twitter fs-xs txt-bl"><span class="icon-twitter ml-1 va-middle d-inline-block vpmd:mt-1 mr-2">
	<svg class="icon icon-twitter " fill="#78bbf4" height="13" width="16" aria-hidden="true">
		<title id="title-twitter-icon-84427">Twitter icon</title>

					<use xlink:href="https://dronedj.com/wp-content/themes/9to5-amp/dist/svg/svg-sprite.svg?ver=1640040212#icon-twitter"></use>
			</svg>

	</span><span>@IshveenaSingh</span></a>						<div class="excerpt fs-xs">
							Ishveena Singh is a versatile journalist and writer with a passion for drones and location technologies. She has been named as one of the 50 Rising Stars of the geospatial industry for the year 2021 by Geospatial World magazine.						</div>
					</div>
				</div>
			</div>
					</div>
	</div>

<div class="posts-carousel mt-5 vpmd:mt-7">
	<amp-carousel layout="fixed-height" type="carousel" height="175" class="i-amphtml-layout-fixed-height i-amphtml-layout-size-defined" style="height:175px" i-amphtml-layout="fixed-height">
					<a class="posts-carousel__item" href="https://dronedj.com/2021/11/29/best-cyber-monday-2021-deals-on-dji-drones/" rel="bookmark">
				<div class="posts-carousel__inner">
					<div class="posts-carousel__image">
						<amp-img class="posts-carousel__amp-img i-amphtml-layout-responsive i-amphtml-layout-size-defined" layout="responsive" height="175" width="350" src="https://i2.wp.com/dronedj.com/wp-content/uploads/sites/2/2021/11/cyber-monday-dji.png?resize=600%2C300&amp;ssl=1" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:50%"></i-amphtml-sizer>
						</amp-img>
					</div>
					<div class="posts-carousel__text fs-sm-md txt-wht">
						Best Cyber Monday deals on DJI drones					</div>
				</div>
			</a>
					<a class="posts-carousel__item" href="https://dronedj.com/2021/11/30/great-drone-deals-still-on-offer-in-cyber-mondays-wake/" rel="bookmark">
				<div class="posts-carousel__inner">
					<div class="posts-carousel__image">
						<amp-img class="posts-carousel__amp-img i-amphtml-layout-responsive i-amphtml-layout-size-defined" layout="responsive" height="175" width="350" src="https://i2.wp.com/dronedj.com/wp-content/uploads/sites/2/2021/02/DJI-FPV-drone-combo.jpg?resize=600%2C300&amp;ssl=1" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:50%"></i-amphtml-sizer>
						</amp-img>
					</div>
					<div class="posts-carousel__text fs-sm-md txt-wht">
						Great drone deals still on offer in Cyber Monday’...					</div>
				</div>
			</a>
					<a class="posts-carousel__item" href="https://dronedj.com/2021/11/25/dji-black-friday-mini-2-drone-deals/" rel="bookmark">
				<div class="posts-carousel__inner">
					<div class="posts-carousel__image">
						<amp-img class="posts-carousel__amp-img i-amphtml-layout-responsive i-amphtml-layout-size-defined" layout="responsive" height="175" width="350" src="https://i0.wp.com/dronedj.com/wp-content/uploads/sites/2/2020/11/dji-mini-2-header.png?resize=600%2C300&amp;ssl=1" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:50%"></i-amphtml-sizer>
						</amp-img>
					</div>
					<div class="posts-carousel__text fs-sm-md txt-wht">
						2 unbeatable Black Friday deals on DJI Mini 2, Mini SE					</div>
				</div>
			</a>
					<a class="posts-carousel__item" href="https://dronedj.com/2021/12/06/dji-ebay-refurbished-sale/" rel="bookmark">
				<div class="posts-carousel__inner">
					<div class="posts-carousel__image">
						<amp-img class="posts-carousel__amp-img i-amphtml-layout-responsive i-amphtml-layout-size-defined" layout="responsive" height="175" width="350" src="https://i2.wp.com/dronedj.com/wp-content/uploads/sites/2/2021/12/DJI-Mini-2-major-update.jpg?resize=600%2C300&amp;ssl=1" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:50%"></i-amphtml-sizer>
						</amp-img>
					</div>
					<div class="posts-carousel__text fs-sm-md txt-wht">
						DJI starts the week with cert. refurb sale: Mini 2 Dron...					</div>
				</div>
			</a>
					<a class="posts-carousel__item" href="https://dronedj.com/2021/12/10/online-drone-deals-abound-with-only-14-shopping-days-left/" rel="bookmark">
				<div class="posts-carousel__inner">
					<div class="posts-carousel__image">
						<amp-img class="posts-carousel__amp-img i-amphtml-layout-responsive i-amphtml-layout-size-defined" layout="responsive" height="175" width="350" src="https://i0.wp.com/dronedj.com/wp-content/uploads/sites/2/2021/07/DJI-Air-2S-.jpg?resize=600%2C300&amp;ssl=1" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:50%"></i-amphtml-sizer>
						</amp-img>
					</div>
					<div class="posts-carousel__text fs-sm-md txt-wht">
						Online drone deals abound with only 14 shopping days le...					</div>
				</div>
			</a>
					<a class="posts-carousel__item" href="https://dronedj.com/2021/11/09/dji-discontinued-smart-controller/" rel="bookmark">
				<div class="posts-carousel__inner">
					<div class="posts-carousel__image">
						<amp-img class="posts-carousel__amp-img i-amphtml-layout-responsive i-amphtml-layout-size-defined" layout="responsive" height="175" width="350" src="https://i2.wp.com/dronedj.com/wp-content/uploads/sites/2/2021/11/DJI-Smart-Controller.png?resize=600%2C300&amp;ssl=1" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:50%"></i-amphtml-sizer>
						</amp-img>
					</div>
					<div class="posts-carousel__text fs-sm-md txt-wht">
						B&amp;H Photo shows DJI Smart Controller as discontinu...					</div>
				</div>
			</a>
					<a class="posts-carousel__item" href="https://dronedj.com/2021/12/07/dji-mavic-mini-firmware-update-3/" rel="bookmark">
				<div class="posts-carousel__inner">
					<div class="posts-carousel__image">
						<amp-img class="posts-carousel__amp-img i-amphtml-layout-responsive i-amphtml-layout-size-defined" layout="responsive" height="175" width="350" src="https://i1.wp.com/dronedj.com/wp-content/uploads/sites/2/2021/07/DJI-Mavic-Mini-Quadcopter.jpg?resize=600%2C300&amp;ssl=1" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:50%"></i-amphtml-sizer>
						</amp-img>
					</div>
					<div class="posts-carousel__text fs-sm-md txt-wht">
						DJI Mavic Mini receives new firmware update					</div>
				</div>
			</a>
					<a class="posts-carousel__item" href="https://dronedj.com/2021/11/04/top-ten-reasons-to-buy-the-dji-mavic-3-standard/" rel="bookmark">
				<div class="posts-carousel__inner">
					<div class="posts-carousel__image">
						<amp-img class="posts-carousel__amp-img i-amphtml-layout-responsive i-amphtml-layout-size-defined" layout="responsive" height="175" width="350" src="https://i0.wp.com/dronedj.com/wp-content/uploads/sites/2/2021/11/DJI-MAVIC-3-TOP-10-LIST.png?resize=600%2C300&amp;ssl=1" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:50%"></i-amphtml-sizer>
						</amp-img>
					</div>
					<div class="posts-carousel__text fs-sm-md txt-wht">
						DroneDJ's Top 10 Mavic 3 drone features					</div>
				</div>
			</a>
			</amp-carousel>
</div>

<div id="comments" class="comments-area bg-wht-alt">
	<div class="comments-inner px-4 py-2 wrap-xs">
		<amp-iframe width="600" height="320" layout="responsive" sandbox="allow-scripts allow-same-origin allow-modals allow-popups allow-forms" resizable src="https://9to5mac.com/wp-content/themes/9to5-2015/amp/disqus.html?postlink=https%3A%2F%2Fdronedj.com%2F2021%2F12%2F22%2Fdji-mavic-mini-fly-more-combo-299-deal%2F&amp;shortname=dronedj#73834%20https%3A%2F%2Fdronedj.com%2F%3Fp%3D73834" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:53.3333%"></i-amphtml-sizer>
			<div overflow tabindex="0" role="button" class="comments-area__overflow" aria-label="Show More">
				Show More Comments			</div>
		</amp-iframe>
	</div>
</div>
					</div>
				</article>
			</main>
			
		<amp-next-page deep-parsing="true" data-test="rl" class="i-amphtml-layout-container" i-amphtml-layout="container">
			<script type="application/json">
				[
					{
						"image": "https://dronedj.com/wp-content/uploads/sites/2/2017/09/dronedj-icon-hires.png ",
						"title": "Page 1 | DroneDJ",
						"url": "https://dronedj.com/page/2/?exclude=73834"
					}
				]
			</script>
		</amp-next-page>
		<amp-analytics id="ce44e5d5-4958-4b5e-8fa3-d2403cb4bda8" type="comscore" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"c2":"20278522"}}</script></amp-analytics><amp-analytics id="1ff605cb-f1c8-4ab6-9c92-0ae5773775b2" type="quantcast" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"pcode":"p-18TTuBOnUhD7c"}}</script></amp-analytics>	<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A10.4&amp;blog=145742980&amp;post=73834&amp;tz=-8&amp;srv=dronedj.com&amp;host=dronedj.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"></amp-pixel>
		
</body></html>
